2

Resolved

Performance counters not created during install

description

Thanks to a some immediate feedback, we have discovered an issue that is preventing users from invoking services through the MSE. The current installer is not setting up the performance counters and the runtime engine is throwing an exception when it tries to increment them. We are working on an updated installer now and should have one later today, but in the meantime, please use the following workaround:
 
In a Visual Studio console type:
 
InstallUtil -i "c:\Program Files\Microsoft Managed Services Engine\Microsoft.MSE.Runtime.exe"
InstallUtil -u "c:\Program Files\Microsoft Managed Services Engine\Microsoft.MSE.Runtime.exe"
 
This will set up the perf counters and you should be able to run normally and still uninstall with the current MSI.

comments

KjellSJ wrote Nov 2, 2007 at 2:04 PM

rember to put " around the path to the .exe

KjellSJ wrote Nov 2, 2007 at 2:09 PM

You must also restart the “MSE Catalog Server” and “MSE Runtime Server” services for the changes to take effect.

williamo wrote Nov 2, 2007 at 6:51 PM

Yes, if the Runtime Server is running, you will need to restart it. However, there is no impact to the Catalog Server so there should be no need to restart it.

wrote Nov 2, 2007 at 6:52 PM

williamo wrote Nov 4, 2007 at 5:41 AM

The latest MSI update keeps this issue from affecting the execution of the Runtime Server, however, Perf Counters are still not enabled during installation. We are still determining how best to address this.

wrote Nov 4, 2007 at 5:41 AM

wrote May 31, 2008 at 12:10 AM

wrote Aug 26, 2010 at 8:49 PM

wrote Feb 14, 2013 at 7:08 PM

wrote May 16, 2013 at 9:11 AM

wrote May 16, 2013 at 9:11 AM

wrote Jun 14, 2013 at 7:07 AM