Issue 7290...MSE Install on 64 bit 2008 server will not create database or authenticate

Mar 26, 2009 at 4:06 PM
Has there been any resolution or workaround to this issue being tracked? I have a client where I need to get MSE up and running in order to start deploying out services this week and need to know if I have to go x86 route.

Thanks,
Mar 26, 2009 at 8:38 PM
Yes, we are tracking this. Does the machine not have Visual Studio or SQL Server installed? Can you try installing SQL Server 2008 Management Objects? As a work around you could do the following;

1) Install on another machine.
2) Backup the database.
3) Uninstall.
4) Restore the database.
5) Perform custom install pointing to the existing database.
Mar 26, 2009 at 9:27 PM
I was able to finally get the database up and running by taking a backup of another instance of MSE, and local desktop for development and restoring it onto the actual dev server. However the problem we are encountering is this when starting up the catalog server: 

Unable to connect to repository. Exception: Cannot open database "MSE_REPOSITORY" requested by the login. The login failed. Login failed for user 'NT AUTHORITY\SYSTEM'.

Our catalog service is on another server (the app server) and is trying to hit the repository but runs into the issue where the login fails. The above user is part of the sysadmin group. We even tried setting this service up with a domain admin account that is part of the admin group on the server, but the service doesn't want to start up because it states the login does not have the right permissions. So I am at a loss on this, since the x86 install didn't run into any problems with the similar setup.

Thanks,
Mar 27, 2009 at 12:14 AM
Edited Mar 27, 2009 at 12:16 AM

yes, this problem will occur because the 'NT Authority\SYSTEM' is a local account (local to the machine).  and most likely is the default account during install for the Catalog Servcie (which is a Windows Service).

A domain account can be used for the "MSE Catalog Service" but you will have to do the following:

1. Grant the "log on as a service" tothat account.  This can be done using the local policy manager.
2. Use the HTTPCFG tool to give specific access/permissions to the namespaces used by the endpoint.  You can do it via command line or use the tool mentioned in this blog.  The tool is much easier to use.   (http://blogs.msdn.com/paulwh/archive/2007/05/04/addressaccessdeniedexception-http-could-not-register-url-http-8080.aspx

The namespace reservations that you need to add look like this:
 http://+:80/ServiceCatalog
 http://+:9000/ServiceCatalog

 http://+:9001/ServiceCatalog


3. if you use the same account for the "MSE Runtime Service" you will have to do the same for the endpoints you rill be hosting in MSE.
  
Also remember that the domain account must have access to SQL Server, the MSE_REPOSITORY Database and must be configured to have access objects under the ServiceEngine.  dbo would be easiest to setup.