This project is read-only.

Walkthrough - Introduction

Topics: Usage Scenarios, Technical Questions
Oct 13, 2008 at 5:44 PM
Hi

I am going through the 30 minute walkthrough (introductionlab.aps). I am at the page 4 in the section "create a second endpoint for an operation". I have done exactly as suggested in the section. I go to the service tester and enter the url "http://v-arunag-m9:9210/basiccalculatorservice2?wsdl" and I get the following error.

---------------------------------------------------------------------
"Failed to discover operations from the Uri due to error [Failed to load list of operations from service metadata]. Did you forget to put "?WSDL' or "mex" at the end of the URL? If it is secure, then go to to security tab and try providing Userid and Password. Please see Windows Event Log for more details"
---------------------------------------------------------------------

Interesting thing is that if I put the above url in internet explorer, it successfully shows me the wsdl like the following
---------------------------------------------------------------------
<?xml version="1.0" encoding="utf-8" ?>
- <wsdl:definitions name="service" targetNamespace="http://tempuri.org/" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:wsam="http://www.w3.org/2007/05/addressing/metadata" xmlns:tns="http://tempuri.org/" xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy" xmlns:i0="http://services.microsoft.com/MSE/POX/svc_basiccalculatorservice2" xmlns:wsap="http://schemas.xmlsoap.org/ws/2004/08/addressing/policy" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:msc="http://schemas.microsoft.com/ws/2005/12/wsdl/contract" xmlns:wsaw="http://www.w3.org/2006/05/addressing/wsdl" xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/" xmlns:wsa10="http://www.w3.org/2005/08/addressing" xmlns:wsx="http://schemas.xmlsoap.org/ws/2004/09/mex">
  <wsdl:import namespace="http://services.microsoft.com/MSE/POX/svc_basiccalculatorservice2" location="http://v-arunag-m9:9210/basiccalculatorservice2?wsdl=wsdl0" />
  <wsdl:types />
- <wsdl:binding name="CustomBinding_svc_basiccalculatorservice2Soap" type="i0:svc_basiccalculatorservice2Soap">
- <wsdl:operation name="AddDoubles">
  <wsdl:input name="AddDoublesRequest" />
  <wsdl:output name="AddDoublesResponse" />
  </wsdl:operation>
  </wsdl:binding>
- <wsdl:service name="service">
  <wsdl:port name="CustomBinding_svc_basiccalculatorservice2Soap" binding="tns:CustomBinding_svc_basiccalculatorservice2Soap" />
  </wsdl:service>
  </wsdl:definitions>
---------------------------------------------------------------------

The windows event log shows the following log after getting the above error message from Service Tester.
---------------------------------------------------------------------
Failed to load Bindings node due to error [Exception Information Type[FileNotFoundException] Message[Could not find file 'C:\Users\arun.aggarwal\AppData\Roaming\Microsoft\MSEServiceTester\1.0.0.0\d4fac94e-20a8-42b5-b34e-9731b2290977.exe.config'.] ]
---------------------------------------------------------------------

Can someone help me? I must be missing something simple. I will appreciate your help.

Sincerely
-Arun
Oct 16, 2008 at 5:07 PM
What version of Windows are you running?  If Vista, can you try running the service tester as administrator?