This project is read-only.

Cannot go through sample calculator lab

Oct 10, 2008 at 2:04 PM

I tried importing my custom WCF service and then creating endpoint and runtime server but nothing is listening on designated ports.

So I decided to try with sample Calculator lab step by step and the result is exactly the same. I copied URI from runtime server endpoint, pasted it into web browser, appended with ?wsdl and 'page' is not found. The same is with service tester. I can see using netstat that nothing is listening on required ports.

What could be wrong? The error log is clear.

Oct 10, 2008 at 9:35 PM
There can be few things that you can check:
1. Check the host name prop of the runtime server. It should be the same as the machine name where your runtime server is running
2. There should be at least one end point associated with the runtime server
3. There should be at least one published operation attacehd to the endpoint

I hope that helps.
Oct 10, 2008 at 9:46 PM
Ad 1, 2 and 3 - everything looks ok. I'm going to try lab scenario on the third computer. Maybe I'm missing something. Two services are started: catalog service and runtime service. It was installed on SQL Server Express.
Oct 13, 2008 at 3:28 PM
The problem is solved. It was caused by hostname mismatch. I configured computer name with full qualified domain name and the runtime host was looking by simple, short name :(