Unable to Call the previous version operations

Topics: Technical Questions
Aug 31, 2010 at 10:49 AM

Can any body tell how to call a operation with different verions.I have tried by giving the version number in the Action part of the MSE Service Tester.But it is giving the results of the latest version.Following is my sample method in the wcf service. 

public stringGetVersion()

{

return "Version 1.0.0.0";

 

}

 

 

 I have modified the above method and imported the method with different version number(2.0.0.0) and added it to the same end point.

 

public string GetVersion()

{

return "Version 2.0.0.0";

 

 

}

When i test the method with service tester by passing the Action parameter as GetVersion:1.0.0.0 , I am getting "Version 2.0.0.0" as result instead of "Version 1.0.0.0".

Can any one tell what is the issue with this approach.Also can anyony let me know how to call a specific version operation programatically.