Issue updating data entities [Solved]

Jun 9, 2010 at 6:42 PM

We, at our company, are facing a "little" issue when updating data contracts. In those data contracts, we use some imports, which are updated as well, since appears a new version with everything new. The problem is, we cannot (should be read as don't know how) associate the new version of the dependency to the data entity. After updating in the operation and resource to the new version of the primary data entity, it still uses the first version, in the wsdl it still shows the old one, even after restarting both the catalog and the runtime.

We are using the December CTP

Can someone help with this?

Jun 10, 2010 at 12:37 PM

Hi,

Follow the below steps.

Steps to Import or Update the DataEntity

  1. From the Model Viewer , Select Tools --> Managed Services Model Components --> Data Entity.
  2. You can see a Wizard. Click Next.
  3. Select the schema that you wish to update.
  4. From the List below Schema Objects , select the Schema Object that you want to update and click next.
  5. You see the Current version. Just click Next.
  6. You will see an option Edit schema option selected. Click Next.
  7. Paste the updated schema in the text box specified. Click Next when done.
  8. Click Next. Will add this to the schema Object.
  9. Once you refresh the Model Viewer , you can click on the DataEntity , and that it contains both the old and the new versions of schemas.
  10. But In order for the resource to take the New schema , you will have to go to Layout -->End To End Item Management.
  11. Drag and drop the updated Dataentity onto the Operation associated to the DataEntity.
  12. MSE Model Viewer will prompt the user with a window named “AsscioateSchemaObjectWindow”. Select the Latest version.
  13. Once done , Click OK, Click Apply on the operation.
  14. You can see that the latest dataentity is using the schema you wanted.

 

Jun 10, 2010 at 4:19 PM
Hi, worked like a charm ;) Thank you very much