MSE Server 2008 Install Issue

Topics: Technical Questions
Apr 20, 2010 at 9:41 PM
Edited Apr 20, 2010 at 9:52 PM

I am having an issue installing MSE Dec 2009 CTP on a Windows Server 2008 Standard SP1 server.  After the installation is complete and it goes into "Starting services", it suspends for awhile and then eventually I get the following error:

Service 'MSE Catalog Server' (Microsoft.MSE.Catalog.ServiceHost.exe) failed to start. Verify that you have sufficient privileges to start system services.

I am using a service account for both Catalog/Runtime access.  This has been given access to the SQL server as well as setup in the administrator group on the machine.  I even tried turning off UAC on the server.  We do have Symantec EndPoint Protection installed, however we turned it off.  This is really annoying because the only options I recieve are Retry or Cancel.

 

Any ideas?  Where is the MSE Catalog Server located and does it require any extra permissions on Server 2008 or SQL Server 2008?

 

Thanks,

Travis

Apr 21, 2010 at 7:25 AM

Hi Travis,

Can you upgrade to the latest build available on Codeplex for MSE please.

Regards,

Manoj

 

Apr 21, 2010 at 3:47 PM

Sorry, the first post had a typo I edited it afterwards.  I am using the MSE 7.5 Dec 2009 CTP.  I have recieved the error with both the x64 & x86 versions.

Travis

Apr 22, 2010 at 5:57 AM

Hi,

Can you quickly check and provide the service user access to the local machine considering that this is a single machine installation.

perform the following steps :

windows->run->type secpol.msc-->opens a window named "Local Security policy"-->Local policies-->UserRightsAssignment-->Log on as a Service.

 

Double click that and add the current service user accoubnt there. close this window. Try restarting the catalog service from the Services.msc window.

Regards

Manoj

May 5, 2010 at 4:37 PM

Thank You! That solved the problem.  I'm still not used to all these new Windows 2008 security settings, there is alot of them!

Sep 23, 2010 at 9:01 AM
Edited Sep 23, 2010 at 9:05 AM

For future reference, this error can also occur for some reason if the services timeout during startup.

Create the Dword LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ServicesPipeTimeout if its not there and set it to decimal value 60000. This will set the timeout to 60s instead of the default 30s. Reboot and try the installation again.